How to fix stuck Mac OS X clipboard – won’t copy/paste anything new

Something has been bugging me with OS X for a while — sometimes the OS X clipboard (officially known as “pasteboard”) gets stuck and won’t accept any new ‘copied’ content. Instead, when you ‘paste’ in any app, the clipboard always pastes back the last thing you successfully copied.

One solution to this is to reboot the Mac, but since Mac OS X is generally so stable and doesn’t need to be periodically rebooted as a matter of course, rebooting a machine with many open apps and windows can be a hassle.

Searching for this issue online provides a lot of bad advice (one website I saw said “repair permissions and if that doesn’t work, reinstall the OS”… terrible advice.)

Other websites incorrectly advise to kill the PBS process and restart it.

Apple’s manual page for PBS notes itย is not related to the Pasteboard process. Instead, the correct process to kill is PBoard.

So, to fix a stuck clipboard (pasteboard) problem, you simply need to:

1. Open your application folder

2. Open the utilities subfolder

3. Open the Activity Monitor app

4. Type “pboard” into the search box at the top right

5. In the search results below, there should only be one result — a row listing the “pboard” process. Highlight it by clicking on it.

6. Click the “x” button at the top left of the window which represents ‘quit this process’

Once you’ve done that, OS X will kill the faulty PBoard process and re-establish it with a fresh one automatically. Your clipboard should be back to normal.

I have a suspicion that this stuck clipboard is a bug in OS X Mavericks 10.9 – I don’t recall it happening before I installed that. It is still an (infrequent) current problem as at 10.9.2.


61 Replies to “How to fix stuck Mac OS X clipboard – won’t copy/paste anything new”

  1. may be a particularly bad offender. I have seen it be broken for one app and not others. This did fix Pages clipboard on Yosemite. (El Cap too buggy for me.)

  2. Did anyone have any luck with this? It drives me crazy. I have to close all my applications and log out, sometimes more than one time a day.

  3. Hello,
    It’s not working for me either. The interesting thing is that I can copy-n-paste between SOME apps only. For example: Firefox & Terminal. Unfortunately, the drag between Finder windows is not working. No idea, what’s wrong, but I see this on regular basis.

  4. Did not work for me. btw this always happens via Chrome browser for me when copy pasting URL. Thats what triggers it.

  5. Same for me also, copy paste from Chrome browser. I killed the pboard multiple times, no luck so far.

  6. for me it was Apple’s Notes app that was blocking copy/paste. After closing it – everything started to work again as before.

  7. This process didn’t work for me, but until I found this post, I thought I was losing my mind. I can’t paste between Pages (5.6.2) documents. Running 10.10.5. The last copied item was a URL from Firefox (not Chrome).

  8. God Bless you! I had tried all types of other things that hadn’t worked. Thank you so much!

  9. This worked for me. One additional step is that I needed to quit and restart the apps that were affected. Better than rebooting the whole machine.

  10. I have tried all the suggestions noted and still have been unable to copy and paste from one application into Word or notepad. I can copy and paste or cut and paste within Word however. Where it not for my iPad Pro I would be unable to continue working at all.

  11. Absolutely unacceptable Apple…. Here I am in macOS Sierra and the thing that came with the ORIGINAL MAC is broken?!?!?

  12. I have struggled with this exact same issue for months. It is time apple fixed it – there are days where I cannot copy and paste anything ….the same thing is stuck in the memory until I reboot the computer – soemthing I do not like to do as it causes me to have to close a dozen operations.
    this is such a basic thing I cannot understand how it cannot be permanently fixed.

  13. The above didn’t fix mine, either. THIS FIXED MINE:
    Using Copy or Cut to Delete the Clipboard
    Highlight any text on any window on the Mac, including a TextEdit document, words on a Web page or even the title of a file in Finder. To take up as little memory in the clipboard as possible, you can highlight a single letter, a space between two words or a punctuation mark.

    Press “Command” and “C” at the same time on the keyboard to copy the text to your clipboard. This deletes any text that was in the clipboard and replaces it with what you just copied.

    Press “Command” and “X” to cut the text on an editable document instead of copying it if you want to ensure that you cleared the clipboard successfully. Without moving the cursor, immediately press “Command” and “V” to paste the text back exactly where it was. This illustrates that the clipboard contains the text you just copied without altering your document.
    credit: AZCentral

  14. Hi Cindy, and Dan, Both of these suggestions do not work for me. I have the issue where I can only c/p in word from word. No pdf’s, no webbrowser txt, nothing from rtf. Only same to same app c/p.

  15. How would I do this for Windows 10
    I copy and paste once then when I click on “copy to clipboard” and paste for something else I get the last thing I copied. Is this how I would fix it?

  16. Dan, thanks so much for the suggestion. Solved my issue within Pages, that meant I couldn’t copy or paste from one document to another.

    Here’s hoping I remember the way to do it when/if it happens again.

    Many thanks

  17. Thank you soooo much! Copy paste malfunction is a huge bug w/ High Sierra and none of the forums I’ve searched had this solution.

  18. if I could, I would dig the grave of late steve jobs and personally kill that dropout bastard myself, that ignorant fool. windows is a champ compared to this shit of operating system

  19. It fixes the copy paste problem for a few minutes, then copy paste doesn’t work again. So your fix doesn’t fix anything at all.

  20. Thank You. This comes often with High Sierra. Strangely, while it’s grayed out of the menu, macros that use the copy paste still work fine when the condition occurs. Nice to know there’s a way to reset it. It would be even nicer of Apple would fix the problem.

  21. Does not work for me – activity monitor cannot terminate pboard even with force quit. On my system 10.13.5 (High Sierra) it is Word that causes the biggest trouble – sometimes when using clipboard it begins doing strange things (I type one letter and it starts changing the text I’m typing in unpredictable ways) or it hangs like now I’m just trying to copy some text between two docx files. The pboard process had 9 threads and when I force-quit Word it went down to 2, so Word is probably hogging it.

  22. This worked for me on Sierra. Thanks! I was flipping out not being able to cut and paste. Now my mind is at peace once again.

  23. I actually have the same issue since Catalina. Tried using this method, and it works but only for an hour or so. Any idea how to solve this permanently?

Leave a Reply

Fill in your details below or click an icon to log in: Logo

You are commenting using your account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

%d bloggers like this: